AlgoBox : Fiche12_EX3
Tester l'algorithme
Cliquer sur ce bouton pour exécuter l'algorithme : 

Résultats

Code de l'algorithme
1   VARIABLES
2     N EST_DU_TYPE NOMBRE
3     K EST_DU_TYPE NOMBRE
4     X EST_DU_TYPE NOMBRE
5     Y EST_DU_TYPE NOMBRE
6     P EST_DU_TYPE NOMBRE
7   DEBUT_ALGORITHME
8     LIRE N
9     P PREND_LA_VALEUR 0
10    POUR K ALLANT_DE 1 A N
11      DEBUT_POUR
12      X PREND_LA_VALEUR random()
13      Y PREND_LA_VALEUR random()
14      SI (Y<sqrt(1-X*X)) ALORS
15        DEBUT_SI
16        P PREND_LA_VALEUR P+1
17        TRACER_POINT (X,Y)
18        FIN_SI
19        SINON
20          DEBUT_SINON
21          TRACER_POINT (X,Y)
22          FIN_SINON
23      FIN_POUR
24    K PREND_LA_VALEUR P/N
25    AFFICHER K
26  FIN_ALGORITHME