AlgoBox : Liste des diviseurs

Donne la liste des diviseurs du nombre N

Tester l'algorithme
Cliquer sur ce bouton pour exécuter l'algorithme : 

Résultats

Code de l'algorithme
1   VARIABLES
2     N EST_DU_TYPE NOMBRE
3     Diviseurs EST_DU_TYPE LISTE
4     I EST_DU_TYPE NOMBRE
5     J EST_DU_TYPE NOMBRE
6   DEBUT_ALGORITHME
7     AFFICHER "Quel nombre ?"
8     LIRE N
9     J PREND_LA_VALEUR 1
10    POUR I ALLANT_DE 1 A floor(sqrt(N))
11      DEBUT_POUR
12      SI (floor(N/I)==N/I) ALORS
13        DEBUT_SI
14        Diviseurs[J] PREND_LA_VALEUR I
15        Diviseurs[J+1] PREND_LA_VALEUR N/I
16        J PREND_LA_VALEUR J+2
17        FIN_SI
18      FIN_POUR
19    POUR I ALLANT_DE 1 A J-1
20      DEBUT_POUR
21      AFFICHER Diviseurs[I]
22      FIN_POUR
23  FIN_ALGORITHME