AlgoBox : DM1_2

Donne la lliste des nombres parfaits inférieur ou égaux à N.

Tester l'algorithme
Cliquer sur ce bouton pour exécuter l'algorithme : 

Résultats

Code de l'algorithme
1   VARIABLES
2     N EST_DU_TYPE NOMBRE
3     S EST_DU_TYPE NOMBRE
4     I EST_DU_TYPE NOMBRE
5     J EST_DU_TYPE NOMBRE
6   DEBUT_ALGORITHME
7     LIRE N
8     SI (N<6) ALORS
9       DEBUT_SI
10      AFFICHER "Aucun nombre parfait"
11      FIN_SI
12      SINON
13        DEBUT_SINON
14        POUR J ALLANT_DE 6 A N
15          DEBUT_POUR
16          S PREND_LA_VALEUR 1
17          POUR I ALLANT_DE 2 A J-1
18            DEBUT_POUR
19            SI (J%I==0) ALORS
20              DEBUT_SI
21              S PREND_LA_VALEUR S+I
22              FIN_SI
23            FIN_POUR
24          SI (S==J) ALORS
25            DEBUT_SI
26            AFFICHER J
27            FIN_SI
28          FIN_POUR
29        FIN_SINON
30  FIN_ALGORITHME