AlgoBox : DM1

Teste si un nombre est parfait.

Tester l'algorithme
Cliquer sur ce bouton pour exécuter l'algorithme : 

Résultats

Code de l'algorithme
1   VARIABLES
2     N EST_DU_TYPE NOMBRE
3     S EST_DU_TYPE NOMBRE
4     I EST_DU_TYPE NOMBRE
5   DEBUT_ALGORITHME
6     LIRE N
7     SI (N==0) ALORS
8       DEBUT_SI
9       AFFICHER "Le nombre 0 n'est pas parfait"
10      FIN_SI
11      SINON
12        DEBUT_SINON
13        S PREND_LA_VALEUR 1
14        POUR I ALLANT_DE 2 A N-1
15          DEBUT_POUR
16          SI (N%I==0) ALORS
17            DEBUT_SI
18            S PREND_LA_VALEUR S+I
19            FIN_SI
20          FIN_POUR
21        SI (N==S) ALORS
22          DEBUT_SI
23          AFFICHER "Le nombre est parfait"
24          FIN_SI
25          SINON
26            DEBUT_SINON
27            AFFICHER "Le nombre n'est pas parfait"
28            FIN_SINON
29        FIN_SINON
30  FIN_ALGORITHME